NB Eclipse IDE can find platform but cannot launch webpage or launch project

Topics for the Eclipse Environment
Post Reply
rsimsiman
Posts: 6
Joined: Wed Apr 07, 2021 12:44 pm

NB Eclipse IDE can find platform but cannot launch webpage or launch project

Post by rsimsiman » Wed Apr 07, 2021 12:54 pm

Hello,

I am working with a MOD 5282 board and am operating it with a VM. I am able to see the board and its IP via NBFind and IPSetup. However, when I try to Launch Webpage from IPSetup, the site cannot be reached even though I have an internet connection. Furthermore, when I try to launch my application in Debug mode, I get the following error:

2159: A socket operation was attempted to an unreachable host.

Can anyone please advise?

Thank you,

Rob Simsiman

User avatar
TomNB
Posts: 411
Joined: Tue May 10, 2016 8:22 am

Re: NB Eclipse IDE can find platform but cannot launch webpage or launch project

Post by TomNB » Wed Apr 07, 2021 3:36 pm

Need all the usual info:
Tools revision, can you ping it, can you see it with a web browser directly?

Can you access it when not using the VM, either by ping or entering the ip address in a web browser?

What are the IP address, mask and gateway settings for:
- Your physical Ethernet interface / main machine running the VM
- The NetBurner device
- Your VM Ethernet interface
- The VM network switch, and is is set to NAT or bridged?
- Any other network interfaces that might be involved

User avatar
pbreed
Posts: 973
Joined: Thu Apr 24, 2008 3:58 pm

Re: NB Eclipse IDE can find platform but cannot launch webpage or launch project

Post by pbreed » Wed Apr 07, 2021 6:14 pm

What application does IPSETUP Report?
Its possible its running an app that does not have a webserver?
(not all example or production apps choose to expose a web page)

rsimsiman
Posts: 6
Joined: Wed Apr 07, 2021 12:44 pm

Re: NB Eclipse IDE can find platform but cannot launch webpage or launch project

Post by rsimsiman » Mon Apr 12, 2021 8:40 am

TomNB - I am able to ping it from the command prompt on both my VM and host machine.

IP address, mask, and gateway settings are as follows (in order of what you posted):
- 169.254.85.35 / 255.255.0.0 / no gateway
- 169.254.85.0 / 255.255.255.0 / no gateway
- 169.254.85.10 / 255.255.255.0 / no gateway
- same as the Ethernet interface, and it is set to bridged
- I have a second network interface set to NAT in order to enable an internet connection

rsimsiman
Posts: 6
Joined: Wed Apr 07, 2021 12:44 pm

Re: NB Eclipse IDE can find platform but cannot launch webpage or launch project

Post by rsimsiman » Mon Apr 12, 2021 10:03 am

pbreed - I was running an app that did not have a webserver. Thank you!

Post Reply