Boot up sequence

Community forum for discussion and support of the PINK product and development kit
Post Reply
Mike2545
Posts: 44
Joined: Wed Aug 20, 2014 6:07 pm

Boot up sequence

Post by Mike2545 » Wed Aug 20, 2014 6:17 pm

Greetings fellow netburner (PINK) enthusiasts. I have a Home Automation system running with a PINK/PIC-Basic/x-bee network controlling 5 HVAC zones. I have noticed a strange behavior upon boot up (after power failure for instance).

My web page has a few HTML radio buttons and the uC side PIC Basic code attempts to read them

Code: Select all

     SEROUT2 pinkTX, pinkBaud, ["!NB0R93"] ' Command To Read  minisplit radio button
     SERIN2  pinkRX, pinkBaud,PauseBit,timeout1,[dec mem2]
Nb_var93 shows a '0' when viewed here http://192.168.1.xx/VV_Show.htm but still times out and will continue to time out until I log into the web page and manually toggle the radio button.

Right now my work around is to have the PINK text me of the error so I can log in and correct this.

Any Ideas? Need more information?

-Mike2545

Mike2545
Posts: 44
Joined: Wed Aug 20, 2014 6:07 pm

Re: Boot up sequence

Post by Mike2545 » Thu Sep 25, 2014 6:31 am

I figured it out. The problem was with the HTML page and how it was loading the NB_Var with 1's & 0's.

Code: Select all

<Input id="radOn1" name="Nb_var93" type= "radio" Value='1' onClick="borderColourChange(true); ">Heat
<Input id="radOff1" name="Nb_var93" type= "radio" Value='0' onClick="borderColourChange(false);">AC
At first I had Value="1"

Tried Value=1

and finally, Value='1'

Thanks for looking

Post Reply