Sending APP file to MOD5282

for everything else
Post Reply
TFT_timmer
Posts: 2
Joined: Wed Sep 12, 2018 8:55 am

Sending APP file to MOD5282

Post by TFT_timmer » Wed Sep 12, 2018 9:32 am

I have a MOD5282 board that has no app and is not accepting any app or possibly I am downloading it wrong. I have the module on my demo board connected through USB (COM10). I can connect using RealTerm or TinyTerm and see the message come up when pressing the reset button. But after the 2 second timeout, I get a message Decomp failed, No Valid app.

I've tried sending the original MOD5282FactoryDemo_APP.s19 file using RealTerm and TinyTerm, no luck. It seems like the file sends but after reset, I get the same No Valid app message. I've tried several of the commands from terminal (FLA, NFLA) but can't get either to work. I just can't get a file into the module.

What is the correct method to send a file?

Thank You

User avatar
TomNB
Posts: 400
Joined: Tue May 10, 2016 8:22 am

Re: Sending APP file to MOD5282

Post by TomNB » Wed Sep 12, 2018 9:52 am

I have attached an app note. If you want to use something other than MTTTY, make sure you are sending as a plain text file. You can try a soft reset, but if that does not work, the power cycle step is very important.
Attachments
SerialDownload201306.pdf
(107.15 KiB) Downloaded 140 times

TFT_timmer
Posts: 2
Joined: Wed Sep 12, 2018 8:55 am

Re: Sending APP file to MOD5282

Post by TFT_timmer » Wed Sep 12, 2018 10:16 am

That PDF was perfect. I was just using the FLA command incorrectly.
Thank You

Post Reply