Recovery NetBurner Time Machine M5282EVA

Discussion to talk about software related topics only.
Post Reply
keithhacke@stlcc.edu
Posts: 1
Joined: Thu May 06, 2021 6:37 am

Recovery NetBurner Time Machine M5282EVA

Post by keithhacke@stlcc.edu » Thu May 06, 2021 3:30 pm

Hi

I am trying to get NetBurner software restored/running on a NetBurner TIme Machine M5282EVA kit. The C:/Nburn/release_tag file (dated 4/21/2003!) says "rel179_EVM_Final).

I just get this error when I boot the board:

Code: Select all

ternal Error #DECE:00000000
Decomp Failed
No Valid app
Netburner EVM5282 Monitor V0.1 Mar 31 2003 10:12:24
HELP for help
nb>
Here are the detailed steps I have tried to recover the board......

The NetBurner Time Machine kit includes the NB software and a Version 1.1 M5282EVA board (aka EVM5282 in the C:\Nburn software directory). I know the hardware is working as I can run my own code on the board (via loading with dBug, which is in external flash).

I have cleared all internal flash where nb> lives with dBug> and then reloaded it from scratch using the provided EvmSetupWizard.exe, which correctly (no errors reported) reloads the internal flash with "Main Applications" and nb> debugger and loads a demo app). Here is the problem I then get after the reload and subsequent reboot:

Code: Select all

ternal Error #DECE:00000000
Decomp Failed
No Valid app
Netburner EVM5282 Monitor V0.1 Mar 31 2003 10:12:24
HELP for help
nb>
The wizard runs completely and says it is loading NetBurner system and APP. Indeed App code appears in the flash when I review it with nb>md commands.

Even when trying to run any of the provided pre-compiled APPs (or my re-compiling them too):

Code: Select all

nb>nfla tictactoe_APP.s19
[ snip - downloads without error]
Waiting 2sec to start 'A' to abort
Internal Error #DECE:FC751551      
Decomp Failed
No Valid app
Here is a complete example session:

Code: Select all

nb>setup
MAC address=00-03-F4-01-52-82
1.)IP Address =192.168.1.99
2.)IP Mask    =255.255.255.0
3.)IP Gateway =192.168.1.1
4.)TFTP Server=192.168.1.117
5.)TFTP File  =
6.)Baudrate  =9600
7.)Wait      =2
8.)Boot to Application
9.)Exceptions CauseReboot
A.)DNS Server =192.168.1.1
B.)Boot Port =0
1-B to change, S to save, X to exitx

nb>nfla tictactoe_APP.s19
B4 Arp Send 
After Arp Send 
Rx Udp[****…..snipped……******Starting address = 02000000

Done
Waiting 2sec to start 'A' to abort
Internal Error #DECE:FC751551   
Decomp Failed
No Valid app

Netburner EVM5282 Monitor V0.1 Mar 31 2003 10:12:24
HELP for help
nb>
If I load an example code .S19 file using serial text download and the nb> dl command, so for example, nb>dl tictactoe.s19, in to ram, and do go or go 02000000, I get "err img" which just prints over and over to the console (tried several different example's and all give same result). I have checked the download using db>md and eyeing a few dozen lines match the .s19 contents, so I know it is loading into ram correctly (and I get a success message from nb> dl command).

Here is one oddity I cannot resolve:

Code: Select all

dBUG> version

ColdFire MCF5282 on the M5282Lite
Firmware v3b.1a.1a (Built on Mar  2 2004 11:46:04)
Copyright 1995-2003 Motorola, Inc.  All Rights Reserved.
Note it says "M5272Lite" which is a different board than the M5282EVA I have. In all my historical files I could only find a dBug image file for this version (which was on the board when I got it out of storage) and not a real M5282EVA image (cannot find anywhere with Google...sigh...) - ANYONE GOT ONE????

But the nb> system seems to run independant of dBug. I cleared external flash (with CF Flasher) where dBug lives to confirm this.

Hope someone can help me get this old (old old) board going again.

Sorry for the super long note, but wanted to show all the details (and the several days work I have tried and been pulling out my hair!!).

Cheers

Keith


-----------------------------------------------------------
Additional info about this kit:
This kit included the NB software, Motorola's M5282eva board, with a 4-digit 7-segment display. The C:/Nburn/release_tag file (dated 4/21/2003!) says "rel179_EVM_Final). There are a dozen+ examples (in c:\Nburn\EVM5282), make, compiler, load etc to rebuild and modify the software. I can rebuild all the software with no errors. There is a BDM debugger module with USB connection to a PC. I used CF Flasher to clear flash and load flash (either dBug or the NB> debugger). All this seems to work correctly - no errors or odd behaviour.

Post Reply