macOS Catalina will not run 2.9.2

Topics for the Eclipse Environment
Post Reply
Rich
Posts: 6
Joined: Tue Jan 16, 2018 1:57 am

macOS Catalina will not run 2.9.2

Post by Rich » Wed Mar 04, 2020 2:10 am

Version 2.9.2 for mac os says it is now 64 bit / Java 8, but i'm still getting the old "No Java runtime present, requesting install."
Of course the java 6 can't be installed now, do I just need to change something in the config?

User avatar
Forrest
Posts: 277
Joined: Wed Apr 23, 2008 10:05 am

Re: macOS Catalina will not run 2.9.2

Post by Forrest » Wed Mar 04, 2020 3:52 pm

Hello,
Yes, this is due to Catalina not allowing 32-bit files, and Java6 provided by apple being only 32 bit. Apple has not released a 64-bit version of the Java6, and likely never will. We have been able to get around this locally by removing the 32-bit check from the apple java6 installation file. We will be making this change available on our download site, but you can get it right now here: https://netburner-nndk.s3.amazonaws.com/Java6forOSX.pkg


Forrest Stanley
NetBurner, Inc
Forrest Stanley
Project Engineer
NetBurner, Inc

NetBurner Learn Articles: http://www.netburner.com/learn

Post Reply