GDB fails with "joined drive" error

Topics for the Eclipse Environment
Post Reply
lslarry86
Posts: 23
Joined: Tue Jul 18, 2017 12:28 pm

GDB fails with "joined drive" error

Post by lslarry86 » Wed Oct 18, 2017 7:56 am

full error message: "the system tried to join a drive to a directory on a joined drive"

Using netburner 2.8.2 on Win10 for 54415, just started this year. I've gotten through one complete project, no major problems. This week I set up a new workspace for a different project, copied in the SimpleADC example, and started changing things. I cannot debug. The code loads and runs ok, but debugging fails with the error message above.

Same PC, same chip, etc., I can debug my other application, no problem. But in the new workspace I get the error and no debug session.

It looks like C:\nburn\gcc-m68k\bin\m68k-elf-gdb.exe is being run in both cases.

I've looked at .project, .cproject, .settings and about a fourth of the content under .plugins, and not found a path to anything but C:

I cannot find a .gdbinit

C:\nburn\gcc-m68k\share\gdb\gdbinit has a weird ubuntu path but does not seem to be run

Sysinternals Process Monitor is not showing any attempt to open files anywhere except C:

Can somebody help me understand how gdb runs here and where it gets its configuration, so I can inspect those files?

Thanks,
Larry

lslarry86
Posts: 23
Joined: Tue Jul 18, 2017 12:28 pm

Re: GDB fails with "joined drive" error

Post by lslarry86 » Wed Oct 18, 2017 8:18 am

Never mind, got it

In the project's .launch file, the line:

<stringAttribute key="org.eclipse.cdt.debug.mi.core.HOST" value="localhost"/>

should have been

<stringAttribute key="org.eclipse.cdt.debug.mi.core.HOST" value="208.1.247.117"/>

where the IP address is correct for my dev board.

Debugging started to work after making that change, found by comparing projects. I'm sure that setting is somewhere in the GUI screens, but this worked too.

So the lesson is, the "joined drive" message is probably some kind of catchall for gdb confused.

petaluma007
Posts: 4
Joined: Wed Jan 19, 2022 3:11 pm

Re: GDB fails with "joined drive" error

Post by petaluma007 » Thu Apr 21, 2022 11:43 am

I am having the same issue and I am using NetBurner 3.3.7 on Win10 for NANO54415. I can't find .launch in my project. Am I missing something?

Error in final launch sequence:

Failed to execute MI command:
-target-select remote 192.168.1.166:2159
Error message from debugger back end:
192.168.1.166:2159: The system tried to join a drive to a directory on a joined drive.
Failed to execute MI command:
-target-select remote 192.168.1.166:2159
Error message from debugger back end:
192.168.1.166:2159: The system tried to join a drive to a directory on a joined drive.
192.168.1.166:2159: The system tried to join a drive to a directory on a joined drive.

User avatar
TomNB
Posts: 461
Joined: Tue May 10, 2016 8:22 am

Re: GDB fails with "joined drive" error

Post by TomNB » Thu Apr 21, 2022 5:19 pm

Hello,

Can you answer the questions from the previous post?

What is the IP address and mask of both the PC and SB70LC?

If find cannot locate the device it could be because:

- You are using a virtual machine and the routing will not work
- You have a firewall or antivirus blocking the pacets
- You have multiple network interfaces on the same subnet, like a wifi and wired ethernet, and the routing is picking the alternate interface.
- Your application does not call the init gdb function.

If you follow the debug sections in the NBEclipse Getting Started Guide, on which step does it fail?

The best case would be to have both your pc and the SB70LC on a wired network with DHCP or know static IP addresses. What are your results in this configuration?

petaluma007
Posts: 4
Joined: Wed Jan 19, 2022 3:11 pm

Re: GDB fails with "joined drive" error

Post by petaluma007 » Tue Apr 26, 2022 6:58 am

IP address of PC: 192.168.1.126
IP address of NANO54415: 192.168.1.166

Opening discover.netburner.com from the PC found the NANO device just fine.

User avatar
Forrest
Posts: 277
Joined: Wed Apr 23, 2008 10:05 am

Re: GDB fails with "joined drive" error

Post by Forrest » Fri Apr 29, 2022 1:59 pm

Hello,

Have you been successful in debugging the gdbdemo example in the examples directory?

Are you sure that you created a NetBurner application launch configuration, and not a C/C++ Application? It sounds like you are using the NetBurner Application type, but just want to verify.

Can you export your debug launch configuration and attach it here? You can do this by going to run->Debug Configurations... Find the debug configuration for your application that is failing, right click on it and select export. Then attach it here. It should not contain any sensitive information, just your debug launch configuration which should include your project name, device target platform, IP address set, and debug settings used.
Forrest Stanley
Project Engineer
NetBurner, Inc

NetBurner Learn Articles: http://www.netburner.com/learn

Post Reply