NBEclipse not working with JDK 6 Update 13

Topics for the Eclipse Environment
Post Reply
MastaThf
Posts: 6
Joined: Fri Apr 03, 2009 11:32 am

NBEclipse not working with JDK 6 Update 13

Post by MastaThf » Fri Apr 03, 2009 11:44 am

Hi guys.
This morning I installed NNDKSetupRel22_rc3.exe, the newest NBEclipse.
Then I installed JDK 6 Update 13, the newest JDK/JRE pack.
In NBEclipse I tried to make a new project with the following properties;
Managed Netburner Project (recommended)
Netburner Device Executable - Network Platform (release, debug both checked)
Fast C/C++ indexer
Target Platform: Default

When I click Finish to create my project, I get an error which reads "Project cannot be created
Reason: Internal error:"

The details point me to java.lang.NullPointerException

I successfully used these exact same project creation parameters on another computer running an older release of NBEclipse and probably an older JDK.

Any ideas why I can't create a project?
Has anyone else had a problem with the newest releases? Anyone care to try to replicate this error?

rnixon
Posts: 833
Joined: Thu Apr 24, 2008 3:59 pm

Re: NBEclipse not working with JDK 6 Update 13

Post by rnixon » Fri Apr 03, 2009 3:20 pm

What does your .log file say?

MastaThf
Posts: 6
Joined: Fri Apr 03, 2009 11:32 am

Re: NBEclipse not working with JDK 6 Update 13

Post by MastaThf » Mon Apr 06, 2009 7:21 am

I wasn't able to create a project so I was writing on a project that someone else created.
I'm still running into the same java errors though.
When I go to build/launch I got an error. This is the error in the log file:

!ENTRY org.eclipse.core.jobs 4 2 2009-03-09 20:43:09.115
!MESSAGE An internal error occurred during: "Launching".
!STACK 0
java.lang.NullPointerException
at nbeclipse.debug.NBLaunchConfiguration.buildForLaunch(NBLaunchConfiguration.java:283)
at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:618)
at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:565)
at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:754)
at org.eclipse.debug.internal.ui.DebugUIPlugin$6.run(DebugUIPlugin.java:944)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)
!SESSION 2009-03-09 20:43:32.302 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_12
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86


What worries me the most is it says java version 1.6.0_12 but it should be on version 13, not 12. I uninstalled all the java JDK/JRE and then reinstalled JDK 6 update 13. Maybe I missed something and that's why Eclipse has the java path confused?

rnixon
Posts: 833
Joined: Thu Apr 24, 2008 3:59 pm

Re: NBEclipse not working with JDK 6 Update 13

Post by rnixon » Mon Apr 06, 2009 8:58 am

What OS are you running? With problems like these you always need to keep things simple and start from the most basic steps and the simplest project, so I would not try to debug things with someone else's project that may have done things differently. Start with your own application wizard generated project.

User avatar
Forrest
Posts: 268
Joined: Wed Apr 23, 2008 10:05 am

Re: NBEclipse not working with JDK 6 Update 13

Post by Forrest » Tue Apr 07, 2009 9:19 am

The error line that your log is pointing to indicates that you do not have a platform selected for your project. Did you create the project in the new NBEclipse, or did you import an old project?

What platform do you have selected if you look at your project properties and select the NetBurner tab.
Forrest Stanley
Project Engineer
NetBurner, Inc

NetBurner Learn Articles: http://www.netburner.com/learn

gab_martinez
Posts: 1
Joined: Thu Jan 21, 2010 10:02 am

Re: NBEclipse not working with JDK 6 Update 13

Post by gab_martinez » Thu Jan 21, 2010 10:05 am

Hi, the best option to import the project is making new project in project wizard with same name of old project, after that only put the old sources in eclipse project tree. That's all.

User avatar
sb70koll
Posts: 35
Joined: Wed Oct 08, 2008 12:43 pm

Re: NBEclipse not working with JDK 6 Update 13

Post by sb70koll » Sun Apr 28, 2019 3:44 am

Forrest wrote:
Tue Apr 07, 2009 9:19 am
The error line that your log is pointing to indicates that you do not have a platform selected for your project. Did you create the project in the new NBEclipse, or did you import an old project?

What platform do you have selected if you look at your project properties and select the NetBurner tab.
I tried to get an 12 year old project back on track and ran into this error. First I had the latest Java on my machine and that was problem no1. When that was solved with an install of JRE1.5 I got this error. The stupid thing was that I pressed to early the finish button. I had to choose the Next button to select the platfor for the SB70. That did it.

Thanks Forrest!
Kind regards, sb70koll
Simplicity is my middle name - Danny Glover - Predator II

Post Reply