Rebuild System Files

Topics for the Eclipse Environment
Post Reply
tpannone
Posts: 43
Joined: Fri Feb 15, 2013 1:04 pm

Rebuild System Files

Post by tpannone » Thu Jan 03, 2019 1:00 pm

I need to make a few small changes to priority levels defined in c:\nburn\include\constants.h. I'm guessing that for these changes to take effect, I need to run either Rebuild Modified System Files or Rebuild All System Files.

When I attempt either, I get the following error message,

"An internal error occurred during: "Clean and Rebuild System Files".
"org.eclipse.core.internal.resources.Folder cannot be cast to org.eclipse.core.resources.IProject"

Any suggestions on the error and the fix? I'm running NBE Release 2.7.7.

tpannone
Posts: 43
Joined: Fri Feb 15, 2013 1:04 pm

Re: Rebuild System Files

Post by tpannone » Mon Jan 07, 2019 8:19 am

Okay. It appears that I broke NBEclipse since what once did build no longer builds. After trying to fix with no luck, I uninstalled and then reinstalled NBEclipse 2.7.7.

After selecting my workspace but before opening any of my project files, I attempted a Rebuild All System Files just to see if it would work. I received the following output in the Console...

AllocationBase 0x0, BaseAddress 0x71110000, RegionSize 0xF0000, State 0x10000
C:\nburn\gcc-m68k\msys\1.0\bin\sh.exe: *** Couldn't reserve space for cygwin's heap, Win32 error 0
./ppp.o ./ahdlc.o ./command.o ./autoip.o ./dhcpc.o ./dhcpd.o ./dhcpd_prefix.o ./dhcpd_standard.o ./pop3.o ./random.o ./tcpupdate.o ./defappname.o ./netrx.o ./nbtime.o ./ntpclient.o ./vjhc.o ./wifisetup.o ./netinterface.o ./multiconfig.o ./taskmon.o ./smarttrap.o ./autoupdate.o ./device.o ./base64.o ./syslog.o ./qspiShared.o ./sdShared.o ./netbios.o ./SendUdpFragment.o ./convert.o ./sdio.o ./sdioBus.o ./sdioBusSpiMode.o ./netDevice.o ./atcommand.o ./wifi.o ./release_tag.o ./release_tagdata.o ./IrqStdio.o ./init.o ./initWithWeb.o ./nbfloatprint.o ./nbiprintf.o ./nbprintf.o ./nbsiprintf.o ./nbsprintf.o ./fdiprintf.o ./fdprintf.o ./timezones.o ./websocket_server.o ./websocket_handler.o
rm -f ./ucosmcfa.od ./software_init.od ./ucosmcfc.od ./ucos.od ./ucosflags.od ./debugtrap.od ./ucosmain.od ./fileio.od ./md5c.od ./system.od ./userparam.od ./librarystubs.od ./aes.od ./itoa.od ./tzsetchar.od ./sha1.od ./main.od ./utils.od ./ip.od ./buffers.od ./arp.od ./dns.od ./udp.od ./udpsocket.od ./tftp.od ./ftp.od ./ftpd.od ./filepost.od ./StreamUpdate.od ./tcp.od ./extraio.od ./httppass.od ./http.od ./httpinternal.od ./httpstricmp.od ./htmldecomp.od ./htmlwritefile.od ./htmlvarplaceholder.od ./iosys.od ./multicast.od ./mailto.od ./new_ops.od ./ppp.od ./ahdlc.od ./command.od ./autoip.od ./dhcpc.od ./dhcpd.od ./dhcpd_prefix.od ./dhcpd_standard.od ./pop3.od ./random.od ./tcpupdate.od ./defappname.od ./netrx.od ./nbtime.od ./ntpclient.od ./vjhc.od ./wifisetup.od ./netinterface.od ./multiconfig.od ./taskmon.od ./smarttrap.od ./autoupdate.od ./device.od ./base64.od ./syslog.od ./qspiShared.od ./sdShared.od ./netbios.od ./SendUdpFragment.od ./convert.od ./sdio.od ./sdioBus.od ./sdioBusSpiMode.od ./netDevice.od ./atcommand.od ./wifi.od ./release_tag.od ./release_tagdata.od ./IrqStdio.od ./init.od ./initWithWeb.od ./nbfloatprint.od ./nbiprintf.od ./nbprintf.od ./nbsiprintf.od ./nbsprintf.od ./fdiprintf.od ./fdprintf.od ./timezones.od ./websocket_server.od ./websocket_handler.od
rm -f /nburn/lib/NetBurner.a
0 [main] us 0 init_cheap: VirtualAlloc pointer is null, Win32 error 487
AllocationBase 0x0, BaseAddress 0x71110000, RegionSize 0xF0000, State 0x10000

Does this make sense to anyone?

ephogy
Posts: 30
Joined: Fri Aug 29, 2008 12:53 pm

Re: Rebuild System Files

Post by ephogy » Tue Jan 08, 2019 9:32 am

I believe this is a cygwin persistent memory bug. Have you tried rebooting your computer?

If you don't want to reboot, you can follow these instructions -- http://jakob.engbloms.se/archives/1403 -- but I would really recommend rebooting first.

tpannone
Posts: 43
Joined: Fri Feb 15, 2013 1:04 pm

Re: Rebuild System Files

Post by tpannone » Tue Jan 08, 2019 11:26 am

I cold boot my development computer every morning, but I will remember that the next time I attempt to rebuild system files.

Thanks for the link too. I will study it.

User avatar
TomNB
Posts: 230
Joined: Tue May 10, 2016 8:22 am

Re: Rebuild System Files

Post by TomNB » Wed Jan 09, 2019 4:40 pm

We do not use cygwin, so that is a strange error to see. This is usually and environment variables issue. To check for that, you can do a command line build and set the environment vars to a know state:

- Open a command prompt
- Go to \nburn and run setenv.bat. This will set the env vars for the
command session
- Go to \nburn\system and type "make"

This is only for tools in the 2.7.x and 2.8.x branches. 3.0 will be slightly different. Also, once you close the command prompt, the variables settings will be discarded - it does not change anything permanently on your computer.

tpannone
Posts: 43
Joined: Fri Feb 15, 2013 1:04 pm

Re: Rebuild System Files

Post by tpannone » Thu Jan 10, 2019 11:05 am

Thanks Tom for the steps.

I also moved the three \nburn\ paths to the front of the system PATH variable. They were originally at the end. The command line build worked properly with no errors this time.

I've not checked rebuilding system files from within the IDE yet. I'll try that the next time.

Post Reply